Sorta Urgent: Skimmer Pump Issue

Discussion in 'Equipment' started by Nav, Jul 4, 2015.

  1. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    Ok sad news... after 24hrs of sitting in 1:1 vinegar:water, I just gave it a try and still the same issue. I took a video of the behavior, pls look at it and advise...

     
  2. wpeterson

    wpeterson Webmaster

    Joined:
    Oct 15, 2014
    Messages:
    770
    Likes Received:
    413
    The impellor is jumping around in it's housing. Usually the impellor has one or two points of contact where it's locked into it's axis. You probably won't get normal behavior without the front housing on to lock the impellor in.

    It may be failing in that mode as well, in which case the impellor may need to be replaced.
     
    Nav likes this.
  3. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    Yup, doesn't rotate when the front housing on...
     
  4. Coral reefer

    Coral reefer President

    Joined:
    Mar 26, 2010
    Messages:
    7,802
    Likes Received:
    1,196
    Order the impeller already
     
    wpeterson and Nav like this.
  5. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    Purchased the impeller (fingers crossed).
     
  6. sfsuphysics

    sfsuphysics Supporting Member

    Joined:
    Nov 7, 2005
    Messages:
    12,844
    Likes Received:
    1,029
    FYI, you really need the front housing on too in order to hold the impeller equally from each wall.
     
  7. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    Agreed, the impeller never rotates when the front housing is on... Waiting for the new impeller :)
     
  8. dswong01

    dswong01 Supporting Member

    Joined:
    Nov 7, 2005
    Messages:
    1,916
    Likes Received:
    43
    I know if the impellers is not spinning correctly on my skimmer changing the grommets at ends of impeller can correct spinning issues. Grommets get worn.
     
  9. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    You mean the rubber caps on both ends of the impeller?
     
  10. Coral reefer

    Coral reefer President

    Joined:
    Mar 26, 2010
    Messages:
    7,802
    Likes Received:
    1,196
    Yep. New impeller should come w them
     
  11. boun11

    boun11 Supporting Member

    Joined:
    Feb 10, 2008
    Messages:
    615
    Likes Received:
    126
    Impeller is always the issue when my skimmer pump is not working.
     
  12. dswong01

    dswong01 Supporting Member

    Joined:
    Nov 7, 2005
    Messages:
    1,916
    Likes Received:
    43
    Depending on the model skimmer you can buy just grommets. or call tech support sometimes they may just send a set doesnt hurt to ask.
     
  13. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    Today I received the impeller I ordered from eBay for $20, slipped it in and it worked like a charm :) The needle wheel & the grommets looked a bit different but overall same size & fit.

    Gave it a rinse and the skimmer is now back & running in my sump. Here's my new question... The foaming is a little different from what I used to have from the old impeller.

    Is it cos of the different type of needle wheel in the impeller -- or -- should I consider a change in the impeller equivalent to a new skimmer and wait for it to break in?
     
  14. wpeterson

    wpeterson Webmaster

    Joined:
    Oct 15, 2014
    Messages:
    770
    Likes Received:
    413
    The foaming and break in are usually about whatever contaminants come on the materials that wear off through use and exposure to the water. If you don't want to wait the 2-5 days it takes to break in, you can usually jump start the process by giving everything a vinegar bath or running the pump in a vinegar solution to clean it off.

    I didn't do any of that and put a new skimmer and pump into my sump with tank water and it foamed like crazy for 2-3 days before it broke itself in. If I had known that was going to happen I would have given it a vinegar bath or pre-run it in a separate solution.

    I've also had this happen from other components in the sump. For example, I had some new filter socks that came with something in them that caused crazy foaming. I went back and pre-washed all the filter socks a few times and it didn't happen when I used them after that.
     
    Nav likes this.
  15. Coral reefer

    Coral reefer President

    Joined:
    Mar 26, 2010
    Messages:
    7,802
    Likes Received:
    1,196
    New filter socks always do that ime.

    You're welcome nav!
     
  16. Nav

    Nav Director of Marketing & Photography

    Joined:
    Apr 2, 2014
    Messages:
    1,421
    Likes Received:
    463
    But I don't have new socks...

    Yea thanks everyone for pushing me in the right direction :)
     

Share This Page